If you're seeing this, you're looking at the old forums. Oops. Please go to http://fabulouspanda.co.uk/macminer/forums or http://forums.fabulouspanda.co.uk/ where the forum has been migrated
can't get BFGminer to run on GeForce GT 330M
  • Hi,

    I'm running CPUMiner with no problems on a macbook pro.  Getting about 17 kHs, and have been successfully mining fastcoint.

    No luck with BFGminer.  Below is part of the error:

     [2013-12-24 00:02:34] Stratum authorisation success for pool 0

     [2013-12-24 00:02:34] Pool 0 stratum+tcp://stratum-eu.doge.luckyminers.com:3313 alive

     [2013-12-24 00:02:35] Network difficulty changed to 402 ( 2.88Gh/s)

     [2013-12-24 00:02:35] New block: ...121678c62a213291 diff 402 ( 2.88Gh/s)

     [2013-12-24 00:02:35] Testing pool 1 stratum stratum+tcp://pool.fabulouspanda.co.uk:9327

     [2013-12-24 00:02:35] Stratum from pool 0 detected new block

     [2013-12-24 00:02:35] Pool 0 is hiding block contents from us

     [2013-12-24 00:02:35] JSON-RPC call failed: {

       "data": null,

       "code": -32601,

       "message": "Method not found"

    }

     [2013-12-24 00:02:35] Switching pool 1 http://pool.fabulouspanda.co.uk:9327 to stratum+tcp://pool.fabulouspanda.co.uk:9327

     [2013-12-24 00:02:35] Testing pool 2 stratum stratum+tcp://freya.syari.net:9327

     [2013-12-24 00:02:35] Init GPU thread 0 GPU 0 virtual GPU 0

     [2013-12-24 00:02:35] CL Platform vendor: Apple

     [2013-12-24 00:02:35] CL Platform name: Apple

     [2013-12-24 00:02:35] CL Platform version: OpenCL 1.2 (Aug 24 2013 21:03:27)

     [2013-12-24 00:02:35] List of devices:

     [2013-12-24 00:02:35] 0 GeForce GT 330M

     [2013-12-24 00:02:35] Selected 0: GeForce GT 330M

     [2013-12-24 00:02:35] Error -30: Creating Command Queue. (clCreateCommandQueue)

     [2013-12-24 00:02:35] Failed to init GPU thread 0, disabling device 0

     [2013-12-24 00:02:35] Restarting the GPU from the menu will not fix this.

     [2013-12-24 00:02:35] Try restarting BFGMiner.

     [2013-12-24 00:02:35] 1 cpu miner threads started, using SHA256 'scrypt' algorithm.

     [2013-12-24 00:02:35] Switching pool 2 http://freya.syari.net:9327 to stratum+tcp://freya.syari.net:9327

     [2013-12-24 00:02:35] Stratum authorisation success for pool 1

     [2013-12-24 00:02:35] Stratum connection to pool 1 resumed

     [2013-12-24 00:02:35] Pool 1 http://pool.fabulouspanda.co.uk:9327 alive

     [2013-12-24 00:02:35] Pool 1 http://pool.fabulouspanda.co.uk:9327 alive

     [2013-12-24 00:02:35] Network difficulty changed to 2.92k (20.90Gh/s)

     [2013-12-24 00:02:35] New block: ...b552bb78 #484307 diff 2.92k (20.90Gh/s)

     [2013-12-24 00:02:35] Stratum from pool 1 detected new block

     [2013-12-24 00:02:35] Pool 1 is hiding block contents from us

     [2013-12-24 00:02:36] Stratum authorisation success for pool 2

     [2013-12-24 00:02:36] Stratum connection to pool 2 resumed

     [2013-12-24 00:02:36] Pool 2 http://freya.syari.net:9327 alive

     [2013-12-24 00:02:36] Pool 2 http://freya.syari.net:9327 alive

     [2013-12-24 00:02:36] Closing socket for stratum pool 1

     [2013-12-24 00:02:36] Pool 2 is hiding block contents from us










































     [2013-12-24 00:02:36] Closing socket for stratum pool 2



    Any ideas?


    Thank you!

    Daniel

  • I wouldn't be surprised if scrypt mining was too much for your GPU, the bitcoin mining hardware comparison ranks the GT 330M at generally under 10MH so if it did mine scrypt it would probably only get a few Kh

    You could try lowering the intensity though!

    Also, when setting up for Alt Coins it's a good idea to just fill in the pool and leave the relevant BTC/LTC field blank or you'll end up with backup BTC/LTC pools in your config file which you can see/remove in miner settings panel-edit config file manually
  • Thank you.  I know it's not a great GPU, but I was hoping to see if it would work and get a little more than the 17 or 18 kHs that my CPU is giving me.  Could it be a driver problem?  Or any idea what these errors mean:

    [2013-12-24 00:02:35] Error -30: Creating Command Queue. (clCreateCommandQueue)

     [2013-12-24 00:02:35] Failed to init GPU thread 0, disabling device 0

     [2013-12-24 00:02:35] Restarting the GPU from the menu will not fix this.


    Thanks again!
    Daniel
  • You definitely won't get faster than your CPU from that GPU I'm afraid, Macs have an Apple written OpenCL driver which makes the same hardware a lot slower on a Mac, and even on other OS that GPU doesn't get over 10Mh BTC mining. The error is that the work is too much for the device which is why turning down the intensity might help
  • Thanks FP,

    I'll play around with it some and continue to mine with CPU.  I'm getting decent return on Fastcoin, like I mentioned, even though it's pretty much worthless at this point; but you never know!  

    Thanks again for all your help and for writing this port.

    Merry Christmas!
    Daniel
  • seftonde,

    I don't believe that card is OpenCL compliant. When it comes to OpenCL cards are either compliant or not. Simple as that. If it's not compliant you'll see errors like you have. (I see a similar issue on my Mac Pro but it's a 2008 thus rightly so)

    *IF* you have a card which is OpenCL compliant, then the next layer of the onion is which version of OpenCL is it compliant with. 1.0? 1.1? 1.2? 2.0? 

    2.0 as a spec was just essentially released so you won't find 2.0 compliant hardware of software yet. 1.2 however has been around and generally speaking most current gen hardware is just that. 

    I know bfgminer works with OpenCL 1.1 because I have tested it on some of my ARM boards just for fun. 

    Have fun!
    Tom


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

In this Discussion